博客统计信息

用户名:wanxiule
文章数:4
评论数:0
访问量:196
无忧币:121
博客积分:72
博客等级:1
注册日期:2012-11-02

最新评论

IPv6/IPv4双栈的MPLS VPN——6VPE实战部署(华为和思科大融合)
2017-03-19 23:19:32
标签:IPv4 IPv6 MPLS
原创作品,允许转载,转载时请务必以超链接形式标明文章 原始出处 、作者信息和本声明。否则将追究法律责任。http://wanxiule.blog.51cto.com/6181351/1908255


个人理解,6VPE(IPv6VPN Provider Edge)是承载IPv6的MPLSVPN,是在保持原有MPLS BGPv4骨干不做大变动的情况下,一种IPv6 MPLS VPN过渡技术。基本部署步骤如下:PE与CE之间存在IPv6 VRF,建立BGPv6的邻居关系;PE与RR之间可以建立IPv6的BGP邻居关系,也可以建立IPv4邻居关系,同步复制VPNv4地址族到VPNv6地址族中,其他配置跟IPv4的MPLS VPN没有什么大区别。

以下为实验室测试环境下部署6VPE案例实战分析:

环境介绍:

1、R1为某思科IOX设备、R4为某华为设备、R2和R3为某思科IOS设备;

2、地址分布:

R1

g0/1/1/2.10

12.1.1.1/30

2001:1::7/127

R4

g1/0/5.10

34.1.1.2/30

2001:1::2/126


g0/1/1/1

14.1.1.1/30


g1/0/7

14.1.1.2/30


Loopback0

1.1.1.1/32


Loopback0

4.4.4.4/32

R2

g3/0/2.10

12.1.1.2/30

2001:1::6/127

R3

g2/0/4.10

34.1.1.1/30

2001:1::1/126


Loopback0

2.2.2.2/32


Loopback0

3.3.3.3/32


Loopback6

2010:2::1/128


Loopback6

2010:3::1/128

3、拓扑图

wKiom1jOoAmjoSyOAACuNlakpL8286.png-wh_50

4、R1与R3之间是EBGP互联,R4与R2之间是EBGP互联,R1与R4之间的IBGP协议为ISIS

实战部署过程呈现:

1、    IPv4的MPLS VPN基础环境部署

关于R2与R3两台思科IOS设备部署BGP,可以参考我的其他博客文章,这里重点列举下R1与R4之间配置的情况。

(1)  R1与R4之间实现ISIS互通

R1

router isis1000

 is-type level-2-only

 net 49.0010.0000.0000.0001.00

 log adjacency changes

 address-family ipv4 unicast

  metric-style wide//这个必须metric格式必须为wide

interface Loopback0

  circuit-type level-2-only

  address-family ipv4 unicast

interface GigabitEthernet0/1/1/1

  circuit-type level-2-only

  address-family ipv4 unicast

(接口与ISIS进程绑定,IOX是在ISIS进程下进程下进行的,这一点跟IOS和下面的华为设备不太一样)

R4

isis 1000

 is-level level-2

 cost-style wide

 network-entity 49.0010.0000.0000.0004.00

 traffic-eng level-2

 log-peer-change

###############################################################################

interface LoopBack0

 description For Global Routing

 ip address 4.4.4.4 255.255.255.255

 isis enable 1000

 isis circuit-level level-2

interface GigabitEthernet1/0/7

 description To-R1-GSR

 undo shutdown

 ip address 14.1.1.2 255.255.255.252

 isis enable 1000

 isis circuit-level level-2

(2)  R1与R4建立MPLS IBGP

R1#show run |be bgp

router bgp4809

 bgp router-id 1.1.1.1

 address-family ipv4 unicast

  redistribute connected

  redistribute static

address-family vpnv4 unicast

neighbor 4.4.4.4

  remote-as 4809

  update-source Loopback0

  address-family vpnv4 unicast

   next-hop-self

(IOX不需要再address-familyipv4地址族下建立邻居关系,只需要在VPNv4地址建立邻居关系即可)

R4

bgp 4809

 router-id 4.4.4.4

 peer 1.1.1.1 as-number 4809

 peer 1.1.1.1 connect-interface LoopBack0

ipv4-familyunicast                     

  undo synchronization

  import-route direct

  import-route static

  peer 1.1.1.1 enable

  peer 1.1.1.1 next-hop-local

(这里也可以修改为undo peer 1.1.1.1 enable也是可以的)

ipv4-familyvpnv4

  policy vpn-target

  peer 1.1.1.1 enable

  peer 1.1.1.1 next-hop-local

(与IOX互联时,这里IPv4-family邻居也可以不需要建立的)

(3)R1与R4建立LDP邻居关系

R1

mpls ldp

 router-id 1.1.1.1

 interface GigabitEthernet0/1/1/1

(IOX同样也是在MPLSLDP进程下将接口也放进来实现LDP与物理接口的绑定)

R4

mpls lsr-id4.4.4.4//华为设备在全局下启用MPLS时无法修改lsr-id,只有关闭mpls时才可以修改)

 mpls

mpls ldp//华为设备在全局下启用MPLS时,才可以修改MPLS Ldp

interface GigabitEthernet1/0/7

mpls

 mpls ldp

(接口下也是一样,只有先启用MPLS时,才可以启用MPLS ldp,且只有在全局下启用MPLS ldp情况下,接口下才可以生效)

(4)验证

R2#ping 3.3.3.3  

(3)  Typeescape sequence to abort.

Sending 5,100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:

!!!!!

Success rateis 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

2、6VPE部署

(1)R1与R4之间MPLS VPNv6建立

R1

router bgp4809

 bgp router-id 1.1.1.1

 address-family ipv4 unicast

  redistribute connected

  redistribute static

address-family vpnv4 unicast

address-family vpnv4 unicast

address-family ipv6 unicast

address-family vpnv6 unicast

 neighbor 4.4.4.4

  remote-as 4809

  update-source Loopback0

  address-family vpnv4 unicast

   next-hop-self

  address-family vpnv6 unicast

   next-hop-self

(IOX的配置很简单,即在v4邻居进程下增加红色部分即vpnv6地址族而已)

R4

bgp 4809

 router-id 4.4.4.4

peer 1.1.1.1as-number 4809

 peer 1.1.1.1 connect-interface LoopBack0

ipv4-family unicast

  undo synchronization

  peer 1.1.1.1 enable

  peer 1.1.1.1 advertise-community

ipv6-family unicast

  undo synchronization                   

  peer 1.1.1.1 enable

  peer 1.1.1.1 advertise-community

ipv4-family vpnv4

  policy vpn-target

  peer 1.1.1.1 enable

  peer 1.1.1.1 next-hop-local

ipv6-family vpnv6

  policy vpn-target

  peer 1.1.1.1 enable

  peer 1.1.1.1 next-hop-local

(华为的配置也比较简单,在ipv6地址族和VPNv6地址族下将ipv4地址族和VPNv4地址族下配置复制一份粘贴过来即可)

(2)R1与R4之间的ISIS、LDP邻居都不需要做任何改变

(3)R1与R2之间、R3与R4之间的IPv6 VRF相关配置与IPv4VRF配置大同小异,唯一区别相应的修改下IPv4地址为IPv6而已,这里不做累赘。

(4)结果验证

R2#show bgp ipv6

BGP tableversion is 8, local router ID is 2.2.2.2

Status codes:s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes:i - IGP, e - EGP, ? - incomplete

 

   Network          Next Hop            Metric LocPrf Weight Path

*>2001:1::/126     2001:1::7                              0 4809 ?

*  2001:1::6/127    2001:1::7                0             0 4809 ?

*>                  ::                       0        32768 ?

*>2001:2::2/128    ::                       0         32768 ?

*>2010:2::1/128    ::                       0         32768 i

*>2010:3::1/128    2001:1::7                              0 4809 64863 i

R2#ping 2010:3::1

 

Type escapesequence to abort.

Sending 5,100-byte ICMP Echos to 2010:3::1, timeout is 2 seconds:

!!!!!

Success rateis 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms

 


本文出自 “万休乐” 博客,请务必保留此出处http://wanxiule.blog.51cto.com/6181351/1908255

分享至
一键收藏,随时查看,分享好友!
crazys_蘑菇
1人
了这篇文章
类别:网络┆阅读(0)┆评论(0) ┆ 返回博主首页返回博客首页

文章评论

 
 

发表评论            

昵  称:
登录  快速注册
验证码:

请点击后输入验证码博客过2级,无需填写验证码

内  容: